Your opinion
1 Replies
oct01 - August 8

Dr. Jacobs,

I'm 31 yrs old with normal hormone tests and an antral follicle count ranging from 11-14. I was put on a long lupron protocol for ICSI. However, upon finishing the bcps I didn't get my period. My u/s showed that I was suppressed but my E2 level wasn't checked. I started Follistim 5 days later but my period didn't start until day 2 of stims. I stimmed for 12 days before HCG. I only created 13 follicles with 11 eggs retrieved, 9 were mature and only 5 fertlized with ICSI.

Q1: Does it sound like I have an egg quality problem even though I'm young, have normal FSH/E2, and good antral follicle counts?

Q2: Could the low fertilization from ICSI be due to the protocol?

Q3: Should I be concerned that my RE doesn't check E2 levels and that I started my stims before my period?

I would really appreciate your insight.

Thanks

 

B. Jacobs, M. D. - August 9

I start Lupron for a long Lupron protocol on pill day 21, and the IVF stimulation on pill day 28. Even though menses on the pill tend to be extremely light, the flow begins about pill day 24 or 25. I have no way of knowing what happened in your case.As far as fertilization rates, it may have been an egg issue, a sperm issue, or possibly a lab issue. The reason I check an estradiol on the day I start the stimulation is to measure response to stimulation.
Good luck.

 

Message:


You must log in to reply.

Are you New to the forum? Sign Up Here! Already a member? Please login below.




Forgot your password?
Need Help?  
New to the forum?

Sign Up Here!


Already a member?
Please login below.





Forgot your password?
Need Help?  
Ask a Question