Why isn't it working?
1 Replies
Lu34 - October 27

I posted this on the other board and realized that the Dr isn't responding now due to personal issues.

I realize this is hard to answer, but I'll give you the brief story. 3 years ago, our son was conceived via our first ivf (after many failed IUI attempts). We had 4 frozen embryos left.

Starting this March, we did a FET. It was a chemical pregnancy. After that we did another FET in May, then an ICSI in July (dh's sperm ended up being abnormal) and another FET in Sept...all resulting in a negative. We had an additional 3 frozen embryos with the July ivf that didn't make the thaw and thus we had only 1 go at frozen.

Our embryos always appear good and my lining is fine. My doctor has done a biopsy to rule out infection.
I've been on metformin for pcos, progesterone injections, estrase (high dosage if fet, low dosage if ivf/icsi) , baby aspirin...and for our last fet, fragmin and prednisone as well (a very low dosage though of only 5mg/day).

What could be going wrong this time around as everythign appears to be perfect? It's so strange too as our first ivf worked with no issues (we even implanted 3 embryos and all 3 initially took), but yet we're having no 'luck' this time around. I'm at a loss and am losing hope.

 

B. Jacobs, M. D. - October 27

I am sorry, but there are just too many variables for me to try to speculate. Please remember that only 30% to 35% of the eggs a woman makes are capable of a successful pregnancy.
Good luck.

 

Message:


You must log in to reply.

Are you New to the forum? Sign Up Here! Already a member? Please login below.




Forgot your password?
Need Help?  
New to the forum?

Sign Up Here!


Already a member?
Please login below.





Forgot your password?
Need Help?  
Ask a Question